How to Set up Page Slider

Vanessa -

Follow these steps to set up your Page Slider widget so that it’s working properly.


 

Step 1. Create a new project in Muse

Open Adobe Muse and go to File > New Site… to create a new project.

 



 

Step 2. Create your Layout

It’s important to have an organized layout before you get started with the widget. Each page needs to have a unique name. The page names must not contain spaces or special characters (ex !@#$%^&*) and each name must be unique (no duplicate names). 
 
 
Leave the Home page alone, that page will be used for placing the Page Slider widget.
 
IMPORTANT: Turn off the master page on the Home page.
 
 
 

 

Step 3. Placing the Widget

Open the Home page.
 
In Muse, go to the Library, open the folder QooQee_Page_Slider, and drag Page Slider v.2.0 onto the page.
 
Tip: If you can't find your Library panel, go to Window > Library.
 
 
 
This is what will appear. There are three main parts of the widget:
  1. MAIN
  2. NAVIGATION
  3. SECTION
 
 
Open your master page, and go back to the Library, open the folder QooQee_Page_Slider, and drag Click & Scroll Fix onto the page.
 
 
 
This is what will appear.
 
 
Click & Scroll Fix is necessary because it ensures that the widget works properly. Make sure that your master page is applied to every page that is a part of your Page Slider (except Home). If you don't want to use a master page, you can simply put Click & Scroll Fix on every page that is a part of your Page Slider (except Home).
 
 

 

Step 4. Setting up the Sections and Slides

By default, the widget comes with two sections. To get more sections, simply duplicate one of the sections by clicking on a section and copying (cmd+c) and pasting it (cmd+v). 
 
Notes:
  • You can have unlimited sections but up to 11 slides for each section.
  • Sections are the pages that will be placed one after another vertically (so you can scroll down to view them).
  • The slides will be placed horizontally next to their sections.
 
Using the sample layout from earlier as an example. This layout has three sections: section1, section2, and section3. Section1 has two slides, 1a, and 1b. Section2 doesn’t have any slides. Section3 has one slide, 3a.
 
 
 
4.1 Section Option
Click on a section and open the options panel. Type in your Section Name and select your Section Sort Order.
 
 
  • Section Name: The name for each section must be different from the other section names.
  • Section Sort Order: This is the order that your sections will appear. So the first section that you want to show up should have a Sort Order of 1, the second one will be 2, the third will be 3, etc.
 
 
4.2 Main Section & Slides
 
The Main Section & Slides is right below the Section Option.
 
If you have slides for the current section, check the box beside Enable Slides. If you don’t have slides for the current section, uncheck this box.
 
Select the number of slides for this section in the dropdown (you can have up to 11)
 
Main Section: Enter the name of your current section page in your Muse project. For example, our first section is section1 so we will put section1 in this box.
 
Slide | Page Name: Enter the page names of your slides. Section1 has two slides so we put 1a and 1b
 
 
 
4.3 ‘Location of the pages’ *Optional
You can choose to have an external URL as your Slides and/or Sections. 
 
 
The default option is Inside this Muse Project. For this option, you only have to enter the name of the page. 
 
 
The other option is Hosted Elsewhere. For this option, use the complete URL of the page. This must include http://
 
 
Wrong Format:
www.site.com
http://www.site.com/page
 
Correct Format:
http://www.site.com/page.html
 
 

 
Now, without any other customization, you can preview your site in the browser to see the page slider effect.
 
To preview your site in browser go to File > Preview Site in Browser or use the quick key (Cmd+Alt+E)
 
Have more questions? Submit a request
Back to FAQ